6. プロジェクトの作成

このチュートリアルでは、Asakusa Frameworkアプリケーション開発用のプロジェクトを作成します。

6.1. テンプレートからアプリケーションプロジェクトを作成

バッチアプリケーションの開発をはじめるには、まずAsakusa Frameworkアプリケーション開発用のプロジェクトを作成します。

このプロジェクトを作成するには、オンライン上に公開されているAsakusa Framework用のプロジェクトテンプレートを利用すると便利です。

プロジェクトテンプレートにはビルドツール(Gradleラッパー)やその設定ファイル、開発環境で利用するライブラリ向けの設定ファイルなどが含まれていて、 このプロジェクト上ですぐにアプリケーションの開発を始めることができます。

6.1.1. Eclipse上でプロジェクトを作成

Shafuを導入したEclipse環境では、ウィザードに従ってプロジェクトテンプレートから新規プロジェクトを作成することができます。

  1. Javaパースペクティブ上のメニューバーから File ‣ New ‣ Gradleプロジェクトをテンプレートから生成 を選択します。
_images/create-project-from-template.png
  1. 新規プロジェクト情報 ダイアログで、プロジェクト名などを入力します。ここでは asakusa-tutorial というプロジェクト名を入力します。
_images/create-project-new.png
  1. テンプレートからプロジェクトの選択 ダイアログで URLを指定してプロジェクトテンプレートをダウンロードする が選択状態になっていることを確認して、画面右の 選択 ボタンを押下します。
_images/create-project-from-catalog.png
  1. プロジェクトテンプレート ダイアログにオンラインに公開されている、利用可能なプロジェクトテンプレートの一覧が表示されます。 ここでは、 Asakusa Project Template <Spark> - 0.10.1 を選択して、 OK ボタンを押下します。
_images/create-project-select-template.png

Note

上記のバージョン選択画面でバージョン 0.10.1 以降の0.10系リリース版 ( 0.10.2 など ) が指定可能になっている場合は、最新のバージョンを選択することを推奨します。

  1. テンプレートからプロジェクトの選択 ダイアログに戻ると、 URLを指定してプロジェクトテンプレートをダウンロードする に選択したプロジェクトテンプレートのURLが入力されています。 この状態で Finish ボタンを押すと、選択したプロジェクトテンプレートに基づいて新規プロジェクトが作成されます。
_images/create-project-select-finish.png

Note

開発環境ではじめてこの手順を実施する際には、Asakusa Frameworkのライブラリをリモートリポジトリからダウンロードするため、数分程度の時間がかかることがあります。

  1. プロジェクトの作成が成功すると、パッケージエクスプローラーに作成したプロジェクトが表示されます。
_images/create-project-package-exploler.png

6.1.2. その他の方法

Shafuを導入したEclipse以外の環境を利用する場合は、以下のURLに公開されているプロジェクトテンプレートをダウンロードして展開してください。

IDEを利用する場合はこのプロジェクトをIDEにインポートしてください。

6.2. プロジェクトのディレクトリ構成

プロジェクトテンプレートから作成したプロジェクトディレクトリには、以下のディレクトリ/ファイルが含まれます。

プロジェクトのディレクトリ構成
ファイル/ディレクトリ 説明
build.gradle Gradleビルドスクリプト
src プロジェクトのソースディレクトリ
build プロジェクトのビルドディレクトリ(ビルド時に生成)
gradlew Gradleラッパーコマンド (Unix)
gradlew.bat Gradleラッパーコマンド (Windows)
.buildtools Gradleラッパーライブラリ

build.gradle はプロジェクトのビルドに関する設定ファイルです。 ビルドに関する設定を変更する場合に、このファイルを編集します。

src ディレクトリは作成するアプリケーションに関するソースファイルを配置します。 通常、 src/main 配下にはアプリケーションの実装に関するファイル、 src/test にはアプリケーションのテストに関するファイルを配置します。

build ディレクトリはプロジェクトをビルドすることで生成される成果物が配置されます。 このディレクトリ配下のファイルはビルドの度にディレクトリの初期化やファイルの再作成が行われる可能性があるので、直接編集しないようにしてください。

Gradleラッパーに関するファイルやディレクトリはコマンドライン上からGradleを使ったビルドを実行するために使用します。 これらのディレクトリやファイルは直接編集しないようにしてください。

6.3. トラブルシューティング

このチュートリアルに関するトラブルシューティングです。

6.3.1. プロジェクト生成メニューが表示されない

Eclipse上でプロジェクトを作成 の手順で、Javaパースペクティブ上のメニューバーから File ‣ New を選択しても、 サブメニューに Gradleプロジェクトをテンプレートから生成 が表示されない。

6.3.1.1. 想定される原因

Shafuのインストール後にJavaパースペクティブが初期化されていない可能性があります。 メニューバーから Window ‣ Perspective ‣ Reset Perspective.. を選択後、再度メニューを表示してください。

それでも表示されない場合は、以下の手順でメニューの設定を行なってください。

  1. メニューバーから Window ‣ Perspective ‣ Customize Perspective.. を選択します。
  2. Customize Perspectiveダイアログから Shortcuts タブを選択します。
  3. 画面左上の SubmenusNew になっていることを確認後、 Shortcut Categories: のリストから Jinrikisha (人力車) を選択します。
  4. OK ボタンを押下して設定を保存した後、再度メニューを表示してください。

上記の手順でもメニューが表示されない場合は、Shafuが正しくインストールされていない可能性があります。 Eclipse環境のセットアップ の手順を確認してください。

6.3.2. プロジェクトの作成に失敗する

Eclipse上でプロジェクトを作成 の手順を実行すると、以下のエラーメッセージが表示されプロジェクトの作成に失敗する。

...
:compileJava FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':compileJava'.
> Cannot find System Java Compiler. Ensure that you have installed a JDK (not just a JRE) and configured your JAVA_HOME system variable to point to the according directory.
...

6.3.2.1. 想定される原因

Eclipseが利用するJavaにJDKが登録されていない可能性があります。 Eclipse環境のセットアップ の手順を確認して、JDKが登録されていることを確認してください。

複数のJava環境が登録されている場合、Eclipse設定画面の Installed JREs ‣ Execution-EnvironmentsJavaSE-1.8 の項目にJDKが表示されていること、 およびJDKにチェックがON(デフォルトで利用する)になっていることを確認してください。